$re = '/^(?=(?:(?!\bno\b).)*\byes\b).*/m';
$str = 'Hello world, major yes here!
Hell no yes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);