re = /^(?=(?:(?!\bno\b).)*\byes\b).*/m
str = 'Hello world, major yes here!
Hell no yes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end