import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9])$";
final String string = "19:45:54\n"
+ "99:45:54\n"
+ "00:45:54\n"
+ ":45:54\n"
+ "19:45:99\n"
+ "09:07:01\n"
+ "19:99:54\n"
+ "25:45:54\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}