import re
regex = re.compile(r"^(0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9])$", flags=re.MULTILINE)
test_str = ("19:45:54\n"
"99:45:54\n"
"00:45:54\n"
":45:54\n"
"19:45:99\n"
"09:07:01\n"
"19:99:54\n"
"25:45:54\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")