#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w+\1"
Local $sString = "thingandthing" & @CRLF & _
"stuffandstuff" & @CRLF & _
"blahandblah" & @CRLF & _
"abcabc" & @CRLF & _
"tootleandpootle" & @CRLF & _
"rappingandtapping" & @CRLF & _
"beepbeep"
Local $sSubst = "\1 \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)