use strict;
my $str = 'thingandthing
stuffandstuff
blahandblah
abcabc
tootleandpootle
rappingandtapping
beepbeep';
my $regex = qr/\w+\1/mp;
my $subst = '\\1 \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";