$re = '/\w+\1/m';
$str = 'thingandthing
stuffandstuff
blahandblah
abcabc
tootleandpootle
rappingandtapping
beepbeep';
$subst = "\1 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;