#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\W+|\W+$"
Local $sString = "`xxxx@gmail.com" & @CRLF & _
"^bbb@yahool.com" & @CRLF & _
"hjhk@grk.co!" & @CRLF & _
"$gh$hd@test.co" & @CRLF & _
"good_email@test.co" & @CRLF & _
"gggh@gh.tom)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")