$re = '/^\W+|\W+$/m';
$str = '`xxxx@gmail.com
^bbb@yahool.com
hjhk@grk.co!
$gh$hd@test.co
good_email@test.co
gggh@gh.tom)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);