package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\W+|\W+$`)
var str = `\`xxxx@gmail.com
^bbb@yahool.com
hjhk@grk.co!
$gh$hd@test.co
good_email@test.co
gggh@gh.tom)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}