const regex = /#Command handler
#===============
#Start of the line
^ #Match the command name
(?<cmd>[\w\d\-\_\?]+)
#Catch as many parameters as possible
(?<params>
(
\ +
(?<pre>[^\-\\\/\w\d\s\n\r]?)
[^\"]*\k<pre>
)*
)?
#Catch as many switches as possible and save them into group
(?<switches>
(
\ +
#Switch starts with -- or - or /
(?:\-\-|\-|\/)
#Gotcha!
[\w\d\_]+
)*
)?
#At the end of the line can be some spaces
\ *$ #End of the line/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#Command handler
#===============
#Start of the line
^ #Match the command name
(?<cmd>[\\w\\d\\-\\_\\?]+)
#Catch as many parameters as possible
(?<params>
(
\\ +
(?<pre>[^\\-\\\\\\\/\\w\\d\\s\\n\\r]?)
[^\\"]*\\k<pre>
)*
)?
#Catch as many switches as possible and save them into group
(?<switches>
(
\\ +
#Switch starts with -- or - or \/
(?:\\-\\-|\\-|\\\/)
#Gotcha!
[\\w\\d\\_]+
)*
)?
#At the end of the line can be some spaces
\\ *$ #End of the line', 'gm')
const str = `help
echo "lol"
shutdown -s /f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}