use strict;
my $str = 'help
echo "lol"
shutdown -s /f';
my $regex = qr/#Command handler
#===============
#Start of the line
^ #Match the command name
(?<cmd>[\w\d\-\_\?]+)
#Catch as many parameters as possible
(?<params>
(
\ +
(?<pre>[^\-\\\/\w\d\s\n\r]?)
[^\"]*\k<pre>
)*
)?
#Catch as many switches as possible and save them into group
(?<switches>
(
\ +
#Switch starts with -- or - or /
(?:\-\-|\-|\/)
#Gotcha!
[\w\d\_]+
)*
)?
#At the end of the line can be some spaces
\ *$ #End of the line/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}