// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)#Command handler
#===============
#Start of the line
^ #Match the command name
(?<cmd>[\w\d\-\_\?]+)
#Catch as many parameters as possible
(?<params>
(
\ +
(?<pre>[^\-\\\/\w\d\s\n\r]?)
[^\"]*\k<pre>
)*
)?
#Catch as many switches as possible and save them into group
(?<switches>
(
\ +
#Switch starts with -- or - or /
(?:\-\-|\-|\/)
#Gotcha!
[\w\d\_]+
)*
)?
#At the end of the line can be some spaces
\ *$ #End of the line"#).unwrap();
let string = "help
echo \"lol\"
shutdown -s /f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}