const regex = new RegExp('(?m)^>\\s*', 'mg')
const str = `
On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
> Physician User
>
> Physician,
> There is a new post for you!
> *Jeremy Wheaton*
> Open Community=C2=AE
>
> Post`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}