use strict;
my $str = '
On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
> Physician User
>
> Physician,
> There is a new post for you!
> *Jeremy Wheaton*
> Open Community=C2=AE
>
> Post';
my $regex = qr`(?m)^>\s*`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}