using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(t)(?:[hanks]{4,5}|hx|anx)\b";
string substitution = @"$1hanks";
string input = @"Fix:
Tanks <-- there's a chance they actually mean _tanks_.
thx
tanx
thansk
tahnks
Leave:
tank
task
tasks
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}