// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(t)(?:[hanks]{4,5}|hx|anx)\b").unwrap();
let string = "Fix:
Tanks <-- there's a chance they actually mean _tanks_.
thx
tanx
thansk
tahnks
Leave:
tank
task
tasks
";
let substitution = "$1hanks";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}