re = /\b(t)(?:[hanks]{4,5}|hx|anx)\b/i
str = 'Fix:
Tanks <-- there\'s a chance they actually mean _tanks_.
thx
tanx
thansk
tahnks
Leave:
tank
task
tasks
'
subst = '$1hanks'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result