$re = '/\bnip\s*\d{10}\b/';
$str = 'hello alpha 1111111111 allla 2322322321 nip 5260305006 pin 5260305006 nipp 5260305006';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);