// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bnip\s*\d{10}\b").unwrap();
let string = "hello alpha 1111111111 allla 2322322321 nip 5260305006 pin 5260305006 nipp 5260305006";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}