re = /\bnip\s*\d{10}\b/
str = 'hello alpha 1111111111 allla 2322322321 nip 5260305006 pin 5260305006 nipp 5260305006'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end