#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<errore(.*)<\/errore(.){0,2}>"
Local $sString = "<RISPOSTA_ALLEGATURA xmlns="http://it/almaviva/disagr/xsd/allegaturaDomandaOut/">" & @CRLF & _
" <STATO>Pratica non presente</STATO>" & @CRLF & _
" <CODICEFISCALE />" & @CRLF & _
" <COD_PRATICA />" & @CRLF & _
" <UFF_PAT />" & @CRLF & _
" <COD_PAT />" & @CRLF & _
" <PROTOCOLLO />" & @CRLF & _
" <COD_LOTTO />" & @CRLF & _
" <ERRORE><CODICE_ERRORE>0</CODICE_ERRORE><MESSAGGIO_ERRORE>cvc-elt.1: Impossibile trovare la dichiarazione dell'elemento 'note'.</MESSAGGIO_ERRORE></ERRORe></RISPOSTA_ALLEGATURA>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")