import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<errore(.*)<\\/errore(.){0,2}>";
final String string = "<RISPOSTA_ALLEGATURA xmlns=\"http://it/almaviva/disagr/xsd/allegaturaDomandaOut/\">\n"
+ " <STATO>Pratica non presente</STATO>\n"
+ " <CODICEFISCALE />\n"
+ " <COD_PRATICA />\n"
+ " <UFF_PAT />\n"
+ " <COD_PAT />\n"
+ " <PROTOCOLLO />\n"
+ " <COD_LOTTO />\n"
+ " <ERRORE><CODICE_ERRORE>0</CODICE_ERRORE><MESSAGGIO_ERRORE>cvc-elt.1: Impossibile trovare la dichiarazione dell'elemento 'note'.</MESSAGGIO_ERRORE></ERRORe></RISPOSTA_ALLEGATURA>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}