const regex = /<errore(.*)<\/errore(.){0,2}>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<errore(.*)<\\\/errore(.){0,2}>', 'gi')
const str = `<RISPOSTA_ALLEGATURA xmlns="http://it/almaviva/disagr/xsd/allegaturaDomandaOut/">
<STATO>Pratica non presente</STATO>
<CODICEFISCALE />
<COD_PRATICA />
<UFF_PAT />
<COD_PAT />
<PROTOCOLLO />
<COD_LOTTO />
<ERRORE><CODICE_ERRORE>0</CODICE_ERRORE><MESSAGGIO_ERRORE>cvc-elt.1: Impossibile trovare la dichiarazione dell'elemento 'note'.</MESSAGGIO_ERRORE></ERRORe></RISPOSTA_ALLEGATURA>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}