$re = '/^\w+\s\d+\s\d+:\d+:\d+\ssvr\-\w+\-nac-(01|02)\s/m';
$str = 'May 20 10:59:30 svr-orw-nac-01 2020-05-20 17:59:30,646
May 20 11:01:01 svr-ies-nac-02 2020-05-20 18:01:01,389';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);