const regex = /^\d+\.0?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.0?$', 'mg')
const str = `0.0.0
1000
12123
01212
10.01
10.0
10.
64.6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}