import re
regex = re.compile(r"^\d+\.0?$", flags=re.MULTILINE)
test_str = ("0.0.0\n"
"1000\n"
"12123\n"
"01212\n"
"10.01\n"
"10.0\n"
"10.\n"
"64.6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")