$re = '/^\d+\.0?$/m';
$str = '0.0.0
1000
12123
01212
10.01
10.0
10.
64.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);