#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?=.*[A-Za-z]).*)|((?=.*[A-Za-z])(?=.*\d).*)|((?=.*[@#$%])(?=.*\d).*)"
Local $sString = "abcsfdASDFASFasdf" & @CRLF & _
"" & @CRLF & _
"1234523562354" & @CRLF & _
"" & @CRLF & _
"~!@#$&*!!!" & @CRLF & _
"" & @CRLF & _
"asdfbsdf1234" & @CRLF & _
"" & @CRLF & _
"123454~!@~~~#%^" & @CRLF & _
"" & @CRLF & _
"abfasf1234123!~!@#$@!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")