$re = '/((?=.*[A-Za-z]).*)|((?=.*[A-Za-z])(?=.*\d).*)|((?=.*[@#$%])(?=.*\d).*)/';
$str = 'abcsfdASDFASFasdf
1234523562354
~!@#$&*!!!
asdfbsdf1234
123454~!@~~~#%^
abfasf1234123!~!@#$@!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);