re = /((?=.*[A-Za-z]).*)|((?=.*[A-Za-z])(?=.*\d).*)|((?=.*[@#$%])(?=.*\d).*)/
str = 'abcsfdASDFASFasdf
1234523562354
~!@#$&*!!!
asdfbsdf1234
123454~!@~~~#%^
abfasf1234123!~!@#$@!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end