#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<[^>]*>"
Local $sString = "<span typeof="mw:File"><a href="/wiki/File:Teramo_mappa.png" class="mw-file-description"><img alt="" src="//upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/150px-Teramo_mappa.png" decoding="async" width="150" height="121" class="mw-file-element" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/225px-Teramo_mappa.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/300px-Teramo_mappa.png 2x" data-file-width="800" data-file-height="647"></a></span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")