import Foundation
let pattern = #"<[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<span typeof="mw:File"><a href="/wiki/File:Teramo_mappa.png" class="mw-file-description"><img alt="" src="//upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/150px-Teramo_mappa.png" decoding="async" width="150" height="121" class="mw-file-element" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/225px-Teramo_mappa.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/6/60/Teramo_mappa.png/300px-Teramo_mappa.png 2x" data-file-width="800" data-file-height="647"></a></span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)