#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Процедура\s+[a-zA-Z0-9А-Яа-яёЁ_]+\(\)\s+Экспорт\s*$[^\n]*\s*КонецПроцедуры"
Local $sString = "&НаКлиенте" & @CRLF & _
"// Процедура выполняется перед началом каждого сценария" & @CRLF & _
"Процедура ПередНачаломСценария() Экспорт" & @CRLF & _
" " & @CRLF & _
"КонецПроцедуры" & @CRLF & _
"" & @CRLF & _
"&НаКлиенте" & @CRLF & _
"// Процедура выполняется перед окончанием каждого сценария" & @CRLF & _
"Процедура ПередОкончаниемСценария() Экспорт" & @CRLF & _
" " & @CRLF & _
"КонецПроцедуры" & @CRLF & _
"" & @CRLF & _
"//////////" & @CRLF & _
"" & @CRLF & _
"&НаСервереБезКонтекста" & @CRLF & _
"Функция ВМетаданныхЕстьСправочникСервер(ВидСправочника)" & @CRLF & _
" Нашел = Ложь;" & @CRLF & _
" Для каждого Элем Из Метаданные.Справочники Цикл" & @CRLF & _
" Имя = Элем.Имя;" & @CRLF & _
" Если НРег(Имя) = НРег(ВидСправочника) Тогда" & @CRLF & _
" Нашел = Истина;" & @CRLF & _
" Прервать;" & @CRLF & _
" КонецЕсли; " & @CRLF & _
" КонецЦикла;" & @CRLF & _
" " & @CRLF & _
" Возврат Нашел; " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")