re = /^Процедура\s+[a-zA-Z0-9А-Яа-яёЁ_]+\(\)\s+Экспорт\s*$[^\n]*\s*КонецПроцедуры/m
str = '&НаКлиенте
// Процедура выполняется перед началом каждого сценария
Процедура ПередНачаломСценария() Экспорт
КонецПроцедуры
&НаКлиенте
// Процедура выполняется перед окончанием каждого сценария
Процедура ПередОкончаниемСценария() Экспорт
КонецПроцедуры
//////////
&НаСервереБезКонтекста
Функция ВМетаданныхЕстьСправочникСервер(ВидСправочника)
Нашел = Ложь;
Для каждого Элем Из Метаданные.Справочники Цикл
Имя = Элем.Имя;
Если НРег(Имя) = НРег(ВидСправочника) Тогда
Нашел = Истина;
Прервать;
КонецЕсли;
КонецЦикла;
Возврат Нашел;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end