const regex = /^Процедура\s+[a-zA-Z0-9А-Яа-яёЁ_]+\(\)\s+Экспорт\s*$[^\n]*\s*КонецПроцедуры/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Процедура\\s+[a-zA-Z0-9А-Яа-яёЁ_]+\\(\\)\\s+Экспорт\\s*$[^\\n]*\\s*КонецПроцедуры', 'gm')
const str = `&НаКлиенте
// Процедура выполняется перед началом каждого сценария
Процедура ПередНачаломСценария() Экспорт
КонецПроцедуры
&НаКлиенте
// Процедура выполняется перед окончанием каждого сценария
Процедура ПередОкончаниемСценария() Экспорт
КонецПроцедуры
//////////
&НаСервереБезКонтекста
Функция ВМетаданныхЕстьСправочникСервер(ВидСправочника)
Нашел = Ложь;
Для каждого Элем Из Метаданные.Справочники Цикл
Имя = Элем.Имя;
Если НРег(Имя) = НРег(ВидСправочника) Тогда
Нашел = Истина;
Прервать;
КонецЕсли;
КонецЦикла;
Возврат Нашел;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}