import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_{2,3}\\(['\"](.*?)['\"]\\)[,;]";
final String string = "echo '<div class=\"alert\"><b>',__('ERROR!'),'</b> ',__('Please fix following errors!'),'</div>';\n"
+ "echo sprintf(__('hello 1'), $name);\n"
+ "___(\"Hello 2\");\n"
+ "echo function ___(\"hello 3\");";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}