$re = '/_{2,3}\([\'"](.*?)[\'"]\)[,;]/';
$str = 'echo \'<div class="alert"><b>\',__(\'ERROR!\'),\'</b> \',__(\'Please fix following errors!\'),\'</div>\';
echo sprintf(__(\'hello 1\'), $name);
___("Hello 2");
echo function ___("hello 3");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);