const regex = /_{2,3}\(['"](.*?)['"]\)[,;]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_{2,3}\\([\'"](.*?)[\'"]\\)[,;]', 'g')
const str = `echo '<div class="alert"><b>',__('ERROR!'),'</b> ',__('Please fix following errors!'),'</div>';
echo sprintf(__('hello 1'), \$name);
___("Hello 2");
echo function ___("hello 3");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}