package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`p\.?o\.? box [^ \r\n\t]+`)
var str = `some text p.o. box 12456 Floor 105 streetName Street`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}