$re = '/p\.?o\.? box [^ \r\n\t]+/';
$str = 'some text p.o. box 12456 Floor 105 streetName Street';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);