#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[01]?[0-9]|2[0-3]):[0-5][0-9](?:[ECMP]ST|UTC)|\d+(?:\.\d+)?[mh])$"
Local $sString = "0:30EST" & @CRLF & _
"00:30PST" & @CRLF & _
"22:15MST" & @CRLF & _
"13:51UTC" & @CRLF & _
"12.5m" & @CRLF & _
"555h" & @CRLF & _
"---" & @CRLF & _
"33:47EST" & @CRLF & _
"1:25GMT" & @CRLF & _
"123:56EST" & @CRLF & _
"12:356EST" & @CRLF & _
"AB" & @CRLF & _
"EST" & @CRLF & _
"h" & @CRLF & _
"55.55.55h"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")