package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[01]?[0-9]|2[0-3]):[0-5][0-9](?:[ECMP]ST|UTC)|\d+(?:\.\d+)?[mh])$`)
var str = `0:30EST
00:30PST
22:15MST
13:51UTC
12.5m
555h
---
33:47EST
1:25GMT
123:56EST
12:356EST
AB
EST
h
55.55.55h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}