import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[01]?[0-9]|2[0-3]):[0-5][0-9](?:[ECMP]ST|UTC)|\\d+(?:\\.\\d+)?[mh])$";
final String string = "0:30EST\n"
+ "00:30PST\n"
+ "22:15MST\n"
+ "13:51UTC\n"
+ "12.5m\n"
+ "555h\n"
+ "---\n"
+ "33:47EST\n"
+ "1:25GMT\n"
+ "123:56EST\n"
+ "12:356EST\n"
+ "AB\n"
+ "EST\n"
+ "h\n"
+ "55.55.55h";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}