use strict;
my $str = '+foo56565+ksjk';
my $regex = qr~(?!^\+)\D~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";