$re = '~(?!^\+)\D~m';
$str = '+foo56565+ksjk';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;