import re
regex = re.compile(r"(?!^\+)\D", flags=re.MULTILINE)
test_str = "+foo56565+ksjk"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)