package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\]]+) \[([^\]]*)\]`)
var str = `Itau [2.265,41]
Bradesco [1.375,21]
Santander Bradesco [784,12]
Caixa 2 []`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}