re = /^([^\]]+) \[([^\]]*)\]/m
str = 'Itau [2.265,41]
Bradesco [1.375,21]
Santander Bradesco [784,12]
Caixa 2 []'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end