import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\]]+) \\[([^\\]]*)\\]";
final String string = "Itau [2.265,41]\n"
+ "Bradesco [1.375,21]\n"
+ "Santander Bradesco [784,12]\n"
+ "Caixa 2 []";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}